NOTICE
The software described in this document is furnished under a license agreement. The
software may be used or copied only in accordance with the terms of the agreement. No part
of this document may be reproduced or transmitted in any form or by any means, electronic
or mechanical, including photocopying and recording, for any purpose without the express
written permission of MicroEdge, LLC. Information in this document may be revised from
time to time without notice.
Confidentiality: This document is provided by MicroEdge, LLC. with the understanding
that its contents will not be divulged to any third party without the written consent of
MicroEdge, LLC.
U.S. Government Users: Use, duplication, or disclosure is subject to the restrictions as set forth in
the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 subparagraph
(c)(1)(ii), or the Commercial Computer Software -- Restricted Rights at CFR 52.227-19, subparagraphs
(c)(1) and (2), as applicable. Manufacturer is MicroEdge, LLC. 619 W. 54th Street, New York, NY
10019.
Copyright © 2016 by MicroEdge, LLC. All rights reserved.
Publication date: April 2016
GIFTS, Essential GIFTS, GIFTS Connections, MyGIFTS, and ReviewerCONNECT are
registered trademarks of MicroEdge, LLC. Other brands, or products, are the trademarks or
registered trademarks of their respective holders, and should be treated as such.

ii

Contents
Welcome to the Report Manager ........................................................................ iii
About the Report Manager ...................................................................... iv
When Should I Use the Report Manager? ............................................... iv

1 Installing the Report Manager .................................1
Overview: Before You Begin .....................................................................2
Providing User Access to the Report Manager ..........................................2
Installing the Report Manager ...................................................................3
Report Manager Security ...........................................................................4
Setting Up SMTP Authentication ..............................................................5

2 Using the Report Manager ......................................7
Overview ...................................................................................................8
Opening the Report Manager ....................................................................8
Running Reports ........................................................................................9
Managing Report Batches ........................................................................10
Editing Batch Information .......................................................................11
Running and Scheduling Report Batches ................................................14

iii

iv

Welcome to the
Report Manager
The chapter describes the functions available in the GIFTS Report
Manager, and when you should use it to run your reports instead of
using the Report Library in the main GIFTS application.

In This Chapter
About the Report Manager.......................................................vi
When Should I Use the Report Manager? ................................vi
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About the Report Manager
The GIFTS Report Manager application allows users to:
❖

Create, manage, and run batches of standard and ad-hoc reports

❖

Export reports in HTML, Word (RTF), Excel, PDF or other file formats

❖

Use a task scheduler to run report batches in the background

❖

Automatically e-mail reports upon the completion of a batch

❖

View logs of batch reporting activity

The GIFTS installation process does not install the Report Manager. To use
the Report Manager, you can install it on one or more GIFTS workstations,
as described in “Installing the Report Manager” on page 1.

When Should I Use the Report Manager?
Many clients will find that they can meet all of their reporting needs by
running reports from the Report Library in the main GIFTS application.
(Select View ➤ Reports from the GIFTS menu to open the Report Library.)
GIFTS uses Crystal Reports XI.
With the Report Manager, you can create batches of reports, and then use a
task scheduler to run your reports. You can schedule your batches to run in
the background at “off peak” times, or you can schedule frequently-needed
reports to run at set intervals—every week, every month...whatever you
need. You can even have batches delivered automatically by e-mail when
they’re done.

vi

About the Report Manager
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Installing the
Report Manager
This chapter explains where the Report Manager should be installed,
and provides instructions for installing the GIFTS Report Manager
on your GIFTS workstations.

In This Chapter
Overview: Before You Begin..................................................... 2
Providing User Access to the Report Manager ......................... 2
Installing the Report Manager................................................... 3
Report Manager Security .......................................................... 4
Setting Up SMTP Authentication.............................................. 5
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Overview: Before You Begin
The process of installing the Report Manager on a workstation is similar to
the process of installing the GIFTS workstation software: by running a Setup
program located on your file server, you install the system files needed to
run the Report Manager and the program icons that are used to start it.
The most efficient way to install the Report Manager is to make it part of
your overall GIFTS installation or upgrade procedure: after you install or
upgrade GIFTS on a workstation, you can run the Report Manager
installation on that workstation.
❖

If you elect not to install the Report Manager on any of your workstations
during your GIFTS installation or upgrade, you can install the Report
Manager on your GIFTS workstations at a later time.

❖

The Report Manager installation process installs system files needed to
run the Report Manager, including files used by GIFTS and files used by
the Crystal Reports XI report viewer. The installation process does not
access the GIFTS database, so you can run it while users are logged in to
GIFTS.

❖

The Report Manager can only be installed on GIFTS workstations that are
properly connected to your database.

Providing User Access to the Report Manager
The Report Manager installation process creates an icon in the Windows
Start menu of the GIFTS workstation that can be used to open the Report
Manager. The default location of this icon is in the same menu as the
workstation’s other GIFTS icons (All Programs ➤ MicroEdge GIFTS).
The installation also creates a “Report Manager” menu item so that users
may open the Report Manager by selecting Options ➤ Report Manager
from the GIFTS Main menu.
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Note: Be sure to install the Report Manager on each of your workstations: if a

user attempts to open the Report Manager from a workstation that has not
been configured to run it, he or she will receive an error message about
unregistered system files.

Installing the Report Manager
Setup files for the Report Manager were copied to your GIFTS file server
during the GIFTS installation or upgrade. To install the Report Manager on
a GIFTS workstation:

1 From the workstation, run the Setup.exe file located in the \GIFTS\Report
Manager Setup directory on your GIFTS file server.
Example: If your network GIFTS directory is installed on P:\GIFTS, the
setup file is located at P:\GIFTS\Report Manager Setup\Setup.exe.

The Setup Welcome screen opens.

2 Click Next. You are prompted to select a Program Folder in the Windows
Start menu.

3 Choose where you want the Report Manager icon to be displayed in the
Windows Start menu, and click Next. A summary of the options you chose
is displayed.

4 Read the summary of the installation options you chose. The Current
Settings field should indicate that a “Report Manager Installation” is to
take place in the folder you specified.

5 Click Next. The installation begins. After the MicroEdge system files are
installed, the Crystal XI System Files Setup Wizard opens.
Note: If you already have the Crystal XI report viewer files installed, no
Setup Wizard appears. Go to step 8.

6 Click Next. You are prompted to confirm that you want to install the
Crystal XI report viewer files.

7 Click Next. The Crystal XI system files are installed, and a confirmation
message is displayed at the end of the process.

Installing the Report Manager
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8 Click Close. You are returned to the Report Manager Setup, which
indicates that the setup is complete.

9 Click Finish to close the Report Manager Setup program.
The installation of the Report Manager on this workstation is now
complete. You may repeat this process on all other GIFTS workstations that
should have access to the Report Manager.

Report Manager Security
To open the Report Manager program and to run reports, GIFTS users must
belong to a user group with the “Run Reports” permission. Users with this
permission can also create and run report batches.
When report batches are run by a task scheduler, the task scheduler
launches ReportManager.exe in “silent” mode so that the reports are run in
the background. To allow background processing, GIFTS login
authentication is not enforced when batches are run by ReportManager.exe
in silent mode.
The parameters sent to the Report Manager from the task scheduler—as
described in “Running and Scheduling Report Batches” on page 14—include
the name of the batch to be run and the GIFTS login of the user who created
the batch. (The user’s password is not included as a parameter, because it
could possibly be viewed by other users in your task scheduler.)
Since no GIFTS login is required, any user who has access to this
information can schedule a batch in silent mode. Note, however, that
without this information unauthorized users cannot run a batch.
To prevent unauthorized users from running report batches:
❖

Users should not share the names of their batches with other users. When
a user views existing batches in the Report Manager, only the batches
created by that user are shown—preventing other users from knowing the
batch name needed to run the batch.
Note: The ‘Admin’ user can view all batches.
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Set up your task scheduler so that users can only view the tasks that they
have created. If other users can view existing tasks, they will be able to
view task parameters entered by other users. For information about
setting up security for your task scheduler, please refer to your task
scheduler’s documentation; MicroEdge cannot assist you with the use of
third-party products.

As an alternative, you can also prevent users from accessing the Report
Manager and from running batches by using Windows security to prevent
them from running the Report Manager program (ReportManager.exe). If a
Windows user is denied permission to run ReportManager.exe, they will not
be able to open the Report Manager or to run batches in silent mode. For
information about setting up Windows security, please contact your IT
department or your Microsoft documentation.

Setting Up SMTP Authentication
If your GIFTS system sends e-mail through an SMTP/POP e-mail server
that requires authentication, you must enter your SMTP login information
before users can use the Report Manager to e-mail batched reports.
To enter the authentication information for your SMTP server:

1 Log in to the Report Manager.
2 From the Report Manager menu, select Tools ➤ Batch Manager. The
Batch Manager is displayed.

3 From the Batch Manager menu, select Setup ➤ Outgoing Mail. The SMTP
Server Authentication window opens:

Setting Up SMTP Authentication
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Note: If the Setup ➤ Outgoing Mail menu option is disabled (“grayed

out”), your GIFTS administrator has not selected the E-Mail Server
Requires Authentication option in the GIFTS External Preferences.
Contact your administrator to verify whether authentication information
is required for your mail server. If so, your administrator must update the
External Preferences before you can proceed.

4 Enter the user and password for your e-mail system and click OK. The
authentication information is saved for use by all Report Manager users.
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Using the
Report Manager
This chapter describes how to run standard and ad-hoc reports and
create report batches with the Report Manager, and how to use a
task scheduler to initiate batch processing of reports.
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Overview
With the Report Manager, you can use batched reports. You can create
batches of reports, and then use a task scheduler to run your reports. You
can schedule your batches to run in the background at “off peak” times, or
you can schedule frequently-needed reports to run at set intervals—every
week, every month...whatever you need. You can even have batches
delivered automatically by e-mail when they’re done.
For more information about the difference between the Report Manager
and the Report Library in the main GIFTS application, please refer to
“When Should I Use the Report Manager?” on page vi.

Opening the Report Manager
To open the Report Manager from a GIFTS workstation:

1 Select the Report Manager from either of the following Windows or
GIFTS menus:
❖

From the Windows Start menu, select All Programs ➤ MicroEdge
GIFTS ➤ Report Manager. You are prompted to log in.
Note: This is the default location for the Report Manager; your
Administrator may have selected a different program folder when he
or she installed the Report Manager. Or, the Report Manager may not
have been installed on your workstation.

❖

From the GIFTS Main menu, select Options ➤ Report Manager.

You are prompted to log in.

2 Enter your GIFTS login and password.
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3 Click OK. The Report Manager opens.

Running Reports
The Report Manager’s interface for running reports is very similar to the
interface of the GIFTS Report Library (which can be viewed by selecting
View ➤ Reports from the Main menu of GIFTS). Therefore, the procedures
for running reports are the same—with the exception of how you run report
batches, which aren’t available in the Report Library.
To run standard and ad-hoc reports, please follow the instructions in your
Using GIFTS Reports manual. Note that the following Report Library features
are not available in the Report Manager’s main view:
❖

You cannot create new search criteria

❖

You cannot add or remove reports from your Favorites folder

❖

You cannot add new reports

❖

You cannot launch other GIFTS applications, or switch to the Organizer
view or Calendar view

Note: These limitations only apply to the Report Manager’s viewer. When

creating batches of reports, as described in the sections that follow, you can
edit your search criteria.

Managing Report Batches
This section describes how to use the Batch Manager to create, open, and
delete report batches. Detailed information about editing batches is
provided in “Editing Batch Information” on page 10.

Running Reports
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About Batches
A batch consists of information about reports that should generated
whenever the batch is run: which reports should be included, what report
titles and search criteria should be used with those reports, and what format
the reports should be saved in after they are processed. You can also define email recipients for a batch so that the reports will automatically be sent by email whenever the batch is processed.
Once you have created a batch, you can run the reports in that batch from
the Batch Manager, or you can use a task scheduler to run the reports later.

Using the Batch Manager
To create, modify, or delete report batches using the Batch Manager:

1 From the Report Manager menu, select Tools ➤ Batch Manager. The
Batch Manager is displayed.
❖

To create a new batch, select File ➤ New from the Batch Manager
menu. The Batch Wizard is displayed. For information about using
the Batch Wizard, see “Editing Batch Information” on page 10.

❖

To edit an existing batch, highlight the batch name in the list and
select File ➤ Edit from the Batch Manager menu. The Batch Wizard
is displayed. For information about using the Batch Wizard, see
“Editing Batch Information” on page 10.

❖

To delete an existing batch, highlight the batch name in the list and
select File ➤ Delete from the Batch Manager menu. You are
prompted to confirm that you want to delete the batch. Click Yes to
delete the batch.

Editing Batch Information
The following sections describe how to set up report batches by editing the
information displayed in the Batch Wizard. To open the Batch Wizard, select
or create a report batch, as described in “Using the Batch Manager” on
page 10.
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Note: You can enter the information on the tabs of the Batch Wizard in any

order that you like. To get started, edit the information in the order
presented here—just keep in mind that before saving the batch, you can go
back to any tab whenever you need to make changes.

Entering the Batch Name and Description
To enter the identifying information for a report batch:

1 Go to the Batch tab of the Batch Wizard.
2 Enter a Short Name of no more than 10 characters. This name is displayed
in the Batch Manager, and will also be the name used when scheduling
batches with a task manager. Enter a name that is short, but which also
contains the information you need to identify the batch in the future.

3 Enter a Description of the batch. Here you can provide additional
information about the batch. The Description will be displayed in the
Batch Manager to help you identify the batch.
You may now proceed to the next section to specify the reports that will be
included in the batch.

Adding Reports to the Batch
To specify the reports that are included in a batch:

1 Go to the Reports tab of the Batch Wizard. Note that at the bottom of this
tab, there is a blank grid. As you add reports to the batch, this grid will list
the reports that you have added.

2 From the Report Category list, select a report category.
3 From the Select a Report to Run list, select a report from the category that
you chose.

4 Click Edit Title if you wish to edit the report’s title and/or subtitles.
Tip: If you plan to run this report on a regular basis, you should avoid the

use of information in your titles—such as specific dates—that might be
incorrect when the batch is run. Use flexible terms like “this quarter.” If

Editing Batch Information
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you’re not sure what titles are appropriate yet, select the search criteria for
the report first, and then return to the title editing fields.

5 Click Select Search to add search criteria for this report. The interface for
selecting and editing searches is the same as the interface used in the GIFTS
Report Library; see Using GIFTS Reports for more information. After
you’ve selected a search, you can click Clear Search to remove it or click
Select Search again to choose a different search.
Tip: As with the report titles, you generally want to a search that will be

valid regardless of when the batch is processed. Use searches with criteria
like “this quarter” instead of specific date ranges.

6 If you have selected a Financial Report or a Budget Report, select the “as
of” date for the report.
Note: “As of” dates for Budget reports allow you to select the fiscal year

the report should run “as of.” For Financial reports, you select a date
relative to the date on which the batch is run (e.g., last quarter, this
month, etc.). For information about the importance of setting an “as of”
date for Financial reports, please see Using GIFTS Reports.

7 Click Add Report to Batch. The report is displayed in the list of batches

8 You may now add more reports to the batch, or delete reports, as needed:
❖

To add another report, repeat steps 2-7.

❖

To remove a report, highlight it in the list of reports at the bottom of
the Batch Wizard’s Reports tab, and click Remove Report from Batch.

Congratulations, you have successfully saved a list of reports that should be
run as a batch. Now, before saving the batch, proceed to the next section to
specify the format in which the reports are saved.
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Specifying the Report Destination
On the Destination tab of the Batch Wizard, you can specify the format in
which the reports are saved when the batch is run. You can also enter e-mail
addresses so that reports are automatically sent as a file attachment when
the batch is completed.
To specify the file format and e-mail recipients:

1 Go to the Destination tab of the Batch Wizard. The formatting, file
destination, and e-mail options are displayed.

If GIFTS uses an SMTP
server to send e-mail, you
can edit the From field to
specify the return address
you want to use.

2 Select the file format for the reports in this batch. All reports in the batch
are saved to this file format.
Important: If you are running ad-hoc reports, you can only export these

reports in the following formats: Adobe Acrobat (PDF), ASCII text,
Microsoft Excel (XLS), Microsoft Word (RTF), Image (TIF), or Hypertext
(HTML).

3 Enter or click Browse to specify the folder to which the reports will be
saved. Each report file is given a filename in the following format: [Report

Editing Batch Information
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title]-MMDDYYYYHHMMSS (the abbreviations indicate the month, day,
year, hour, minute, and second on which the report was run).
Example: If your batch included the Cash Flow Analysis by Program Area 1

report in RTF format and was run in the last moment of the year 2006,
the report’s file name would be:
Cash_Flow_Analysis_by_Program_Area_1-12312006235959.rtf.

4 If you would like to automatically e-mail copies of the reports each time
a batch is run, enter the information needed for e-mail messages:
❖

The Subject you enter is used as the subject of the message.

❖

Enter the message recipients: select “TO” or “CC” from the list, type
the recipient’s address into the available field, and click Add. To
remove recipients, you can select them and click Remove.

❖

Enter the body text that will be sent with each message.

The report files will be sent as an attachment to the message that is
generated each time the batch is run.

5 The Destination options for the batch are now complete. Review the
information in the Reports tab and Batch tab to ensure that it meets your
needs, and click OK to save the batch. You are returned to the Batch
Manager.
Once you have entered all of the information for a batch, you can either run
it immediately using the Report Manager—or use a task scheduler to run
the reports later. Proceed to the next section for more information.

Running and Scheduling Report Batches
The following sections describe how you can run batches from the Report
Manager, or how to use a task scheduler to run batches for a later time.
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Running a Batch from the Report Manager
You can run a batch of reports at any time from the Report Manager. To run
a batch:

1 Open the Reports Manager.
2 From the Report Manager menu, select Tools ➤ Batch Manager. The
Batch Manager is displayed.

3 Select a batch from the list of existing batches. Note that only the batches
you have created are displayed.

4 From the Batch Manager menu, select Action ➤ Run Batch. A process log
displays the progress of the batch as it runs.

5 When the batch is complete, the report files are saved to the folder that
was specified on the Destination tab of Batch Wizard and—if the batch
was set up to generate e-mail—sent as e-mail attachments to the batch’s
recipients. You can click Close to close the process log, Save As to save it,
or Print to print it.
To view the reports, open the report files that were created in the batch’s
destination folder. Each report file has a filename in the following format:
[Report title]-MMDDYYYYHHMMSS (the abbreviations indicate the
month, day, year, hour, minute, and second on which the report was run).
Example: Alpha List of Grantee Organizations-05102006105802.xls

Scheduling Report Batches with a Task Scheduler
You can use any task scheduler to run report batches in “silent” mode using
the parameters described in this procedure. As an example, the instructions
that follow describe how to use Windows Scheduled Tasks; please refer to
your Microsoft documentation for any additional information about
working in Windows.
Important: If your task scheduler allows other users to view your tasks, they

will able to run your batch reports by viewing the parameters in your task.
See “Report Manager Security” on page 4 for more information.
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Important: If you are running Windows 7 or Vista on your workstation, refer

to the instructions located on page 18.
To schedule a report batch as a Scheduled Task in Windows XP:

1 From the Windows Start menu of the GIFTS file server, choose All

Programs ➤ Accessories ➤ System Tools ➤ Scheduled Tasks. The
Scheduled Tasks Control Panel is displayed.

2 Double-click Add Scheduled Task. The Scheduled Task Wizard is
displayed.

3 Click Next. You are prompted to select the program you wish to run.
4 Click Browse and select the ReportManager.exe file located in your GIFTS
directory.

5 Click Open to select the ReportManager.exe file. You are prompted to
enter the name and frequency of the task.

6 Enter a Description for the batch, and select whether you are scheduling
the batch to run once or on a regular basis.

7 Click Next. You are prompted to enter the time and day on which you
want the program to run.

8 Enter a starting day and time.
9 Click Next. You are prompted to enter the login information for the
Windows user account that will be used to run the batch.
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10 Enter the login and password for your Windows user account. Remember
that to run reports you must have full permissions for the GIFTS directory
and all of it subdirectories, and permission to run the ReportManager.exe
program file.

11 Click Next. The Wizard displays the options you selected.
12 Select the “Open advanced properties for this task when I click Finish”
option.

13 Click Finish. The task properties are displayed.
Note: If Windows displays an “access denied” message, the user ID you

entered does not have sufficient access to the GIFTS directory, or the
password you entered was not correct.

14 In the Run field, add a space and “-s” to the end of the path to
ReportManager.exe. This is the switch that instructs the scheduler to run
the batch in silent mode.

15 After the switch, add the name of the batch and the name of the GIFTS
user who created the batch in the following format: ReportManager.exe
-s batch=[batch name] login=[GIFTS user ID].

16 Click OK to save your changes. If you are prompted to re-enter your
Windows login information, re-enter it and click OK.

Running and Scheduling Report Batches
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Scheduling Report Batches on Windows 7, 8 or Vista:
To schedule a report batch as a Scheduled Task from a workstation running
Windows 7 or Vista:

1 Click the Windows Start button. Type Task Scheduler in the search field
and press Enter. NOTE: You can also go to Start > All Programs ➤
Accessories ➤ System Tools ➤ Task Scheduler.

2 When the Task Scheduler window appears, click Create Basic Task from
the Actions section. The Create Basic Task Wizard appears.

3 Enter the Name and Description for the batch, and then click Next.
4 Select when you want the batch to run from the choices listed and then
click Next.
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5 Enter a Start date and time, and the frequency, if needed. Then click Next.

6 Select Start a program, and then click Next.
7 Click Browse and select the ReportManager.exe file located in your GIFTS
directory.

8 Click Open.
9 In the Add arguments field, enter “-s”. This is the switch that instructs the
scheduler to run the batch in silent mode.

10 In the same field after the “-s”, add the name of the batch and the name of
the GIFTS user who created the batch in the following format:
batch=[batch name] login=[GIFTS user ID].

11 Click Next.

Running and Scheduling Report Batches
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12 On the next page, to configure advanced settings, select the Open the
Properties dialog for this task when I click Finish checkbox.

Note: This step is optional and launches the Properties window after you
click Finish which allows you to enter advanced settings.

13 Click Finish.
The Report Manager and Window Scheduled Tasks are now set up to run
your batch at the time you specified, without any further user intervention.
When the batch is complete, the report files are saved to the folder that was
specified on the Destination tab of Batch Wizard and—if the batch was set
up to generate e-mail—sent as e-mail attachments to the batch’s recipients.
When the Report Manager runs in silent mode to create a batch, it generates
a log file that you can review to verify that your batch has run or to view
information about any errors that occurred. For information about the
batch log, please continue to the next section.

Viewing Batch Report Logs
Each time a Report Manager batch is run by a task scheduler, a log file is
generated. You can examine any messages that were generated and verify
that your batch was completed.
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By default, this file is saved to the GIFTS\Logs\ReportManager directory.
The filename will be in the following form:
BatchShortName-MMDDYYYYHHMMSS.log (the abbreviations indicate
the month, day, year, hour, minute, and second on which the task was run).
Example: If the scheduler ran the BOARD_PREP batch at the last moment of

the year 2006, the log’s file name would be BOARD_PREP12312006235959.log.
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